Simon Documents Page Not Accessible

Incident Report for Simon Data

Resolved

This incident has been resolved.
Posted Feb 19, 2025 - 03:32 UTC

Monitoring

Access to the Simon Documents pages have been restored and we are monitoring the results. We apologize for the downtime.
Posted Feb 19, 2025 - 01:52 UTC

Identified

docs.simondata.com is currently unavailable. We are communicating with our partner on resolution. We will post more updates as the issue is resolved. We apologize for the inconvenience.
Posted Feb 19, 2025 - 00:32 UTC