Simon's Syncs Maintenance

Scheduled for Nov 4, 02:00 - 03:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Oct 13, 2025 - 17:31 UTC

Scheduled

Simon's Syncs infrastructure will be undergoing routine maintenance. During this time, campaigns may be delayed.
Posted Oct 20, 2025 - 21:13 UTC
This scheduled maintenance affects: Simon Data Syncs.