Simon Web App and Audience API Disruption

Incident Report for Simon Data

Resolved

This incident has been resolved.
Posted Mar 05, 2025 - 22:14 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 05, 2025 - 21:44 UTC

Investigating

We are currently experiencing a service disruption with the Simon Web App and Audience API. We are investigating the degraded performance.
Posted Mar 05, 2025 - 21:17 UTC
This incident affected: Simon Web App and Simon Audience API.