Third Party Outage: AWS

Incident Report for Simon Data

Resolved

We've successfully recovered from the AWS incident.
Posted Oct 20, 2025 - 10:26 UTC

Monitoring

AWS had an outage that impacted a number of services that we rely on, including our ability to update our Status Page in a timely manner.

The only impacted region was us-east-1. Journeys, Syncs, and Pipes have delayed processing that we are actively recovering from. Incoming events were delayed.

More information on the outage. https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 10:00 UTC
This incident affected: Journeys, Simon Event Trigger Flows, Simon Data Pipes, and Simon Data Syncs.