Snowflake Data Cloud - Degraded Service

Incident Report for Simon Data

Resolved

At this time we are starting to see Snowflake processes recover.
Posted Dec 16, 2025 - 14:23 UTC

Update

Snowflake continues to make progress here, there are some aspects of data sharing that are now operational.
Posted Dec 16, 2025 - 14:11 UTC

Monitoring

Customers utilizing Snowflake services in the following regions are experiencing service disruption:

Regions Impacted:
AWS - US West (Oregon)
AWS - Europe (Ireland)
AWS - Asia Pacific (Mumbai)

Users are unable to execute queries against Snowflake databases, tables, and views. Error message presented: "SQL execution internal error" or similar messages.

Snowflake has identified the root cause and is actively developing a fix -- https://status.snowflake.com/
Posted Dec 16, 2025 - 12:45 UTC
This incident affected: Simon Web App.