Simon Web App Service Disruption
Incident Report for Simon Data
Resolved
This incident has been resolved.
Posted Jan 30, 2024 - 18:21 UTC
Investigating
We are currently experiencing a service disruption with the Simon Web App.

We are monitoring the degraded performance, we will send an additional update in 30 minutes if not resolved.
Posted Jan 30, 2024 - 17:56 UTC
This incident affected: Simon Web App.